[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Running make inside a Guix Container From Outside

From: jgart
Subject: Running make inside a Guix Container From Outside
Date: Mon, 6 Sep 2021 12:57:32 -0400

Hi Guixers,

I started making a quick bash script that started like this:

git clone guix-3000
cd guix-3000
guix environment guix --container
./configure --local-statedir=/var
time make
print "ready for hacking"

One of the problems with the above script is that the `guix environment guix 
--container` blocks `./bootstrap` etc...

I'm thinking of rewriting the script in python or guile using some form of 
async to solve that issue if needed.
Once `guix environment guix --container` is unblocked by me killing the process 
the following commands run outside the container and fail. This is expected.

So, I ran `guix environment guix --container` in one terminal and opened 
another terminal to see if I can
first test running commands in containers from the "outside" with `guix 
container exec`.

I tried `guix container exec PID "./boostrap"` and it didn't fail. In the other 
terminal running the

container I looked to see if there was any change to container's directory 
structure and there was none.

I also ran `guix container exec PID "./configure --localstatedir=/var"` and
`guix container exec PID "time make"`.

Am I misusing `guix container exec`? 

Is it currently possible to run arbitrary commands in guix containers from 
outside guix containers?

all best,
/ 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
\ 77B6 DD35                               /
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||

reply via email to

[Prev in Thread] Current Thread [Next in Thread]