[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

herd can't connect to socket on GNU/Hurd: Connection refused

From: Akib Azmain Turja
Subject: herd can't connect to socket on GNU/Hurd: Connection refused
Date: Wed, 08 Sep 2021 14:48:56 +0600

I've downloaded latest QEMU image from build servers (build details:  Then I booted it with
libvirtd on my Guix System on GNU/Linux.  It booted and the login shell
appeared.  I logined as root without password and tried to install GNU
Hello (just to make sure everything is working).  It failed due to
network problems, although my host machine was connected to the
internet.  Then I tried to ping GNU server:

root@guixygnu ~# ping

But no output appeared, not even an error message!  I checked the return
status immediately:

root@guixygnu ~# echo $?

Then I tried ping localhost, but again it returned 1 without any output.
Then tried to see the available interfaces, but this too failed:

root@guixygnu ~# ifconfig
ifconfig: could not get list of interfaces

Then I booted again with QEMU directly with:

$ qemu-system-i386 -m 512 -snapshot -hda <path/to/image.qcow2>

Again, I face the same problem.  However, this time I noticed a message
from settrans saying "settrans: /servers/socket/1: Device or resource
busy", a message saying the disk is mounted as read-only, (probably) an
error message from fsck showing it's usage, some warnings from Guile
saying "WARNING: (guile-user): imported module (guix build utils)
overrides core binding `delete'", the following messages during boot:

failed to start service: loopback
failed to start service: networking
failed to start service: ssh-daemon
failed to start service: ssh
failed to start service: sshd

Followed by an incomplete backtrace:

           3 (primitive-load "/gnu/store/n9glgyqlb30wjxia0zcx71x9zw9?")
In shepherd.scm:

I saw many other messages, but I didn't get the time to read and copy

Then I tried to check the status of loopback service:

root@guixygnu ~# herd status loopback
error: connect: /var/run/shepherd/socket: Connection refused

Can someone help me with this issue?  The QEMU image is almost unusable
without networking.

Note: all commands and their outputs are copied by hand.

Akib Azmain Turja

This message is signed by me with my GnuPG key.  It's fingerprint is:

    7001 8CE5 819F 17A3 BBA6  66AF E74F 0EFA 922A E7F5

Get it with:

    gpg --recv-keys 70018CE5819F17A3BBA666AFE74F0EFA922AE7F5

See to learn more and protect your
emails and yourself from surveillance.  Please send me encrypted
messages whenever possible.

Never send me Microsoft Office attachments, they use secret proprietary
format so I'll fail to read and trash them; send them in plain text if
possible or in formats like ODF and PDF if your document contains images
or videos. See to
learn more.

Please don't send HTML emails, use plain text.  HTML emails are usually
vulnerable, about thousand times larger than plain text and look ugly to
me.  They contain trackers, so whenever someone opens a messsage he is
tracked by third-party.  See to learn more.

()  ascii ribbon campaign - against html e-mail
/\   - against proprietary attachments

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]