[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix Printing Problems

From: Tobias Geerinckx-Rice
Subject: Re: Guix Printing Problems
Date: Thu, 23 Sep 2021 14:11:37 +0200


Peter 写道:
Greetings! This is my first post. I hope I'm doing it right, and please forgive me if I'm not.

Welcome!  You absolutely are.

http//:localhost:631 brings up a CUPS interface, but produces an error
message: "The web interface is currently disabled. Run "cupsctl
WebInterface=yes" to enable it."

Ah, that wouldn't work anyway: Guix uses read-only configuration files.

 $ sudo cupsctl WebInterface=yes
 Password for root on localhost? ***
 cupsctl: Internal Server Error

I try that but "command not found".

Aside from it not working, you can make cupsctl (along with the other cups commands like lp) available for your user with

 $ guix install cups

or for all users by adding it to the (packages …) field in your system configuration.

Commands I have used like 'systemctl start cups.service' etc
don't work on Guix either. Is there a Guix equivalent?

Guix doesn't have systemd. The equivalent service manager is the GNU Shepherd:

 $ sudo herd restart cups

Attempts to enable the Web interface via the config.scm (GNU Guix
Reference Manual 10.8.7) have also failed.

Now that's odd, because it definitely should. Could you edit your system configuration to read:

    (service cups-service-type
               (web-interface? #t)))

and then apply it by running:

 $ sudo guix system reconfigure [your system .scm]
 $ sudo herd restart cups

and confirm that you still get the same error?

This ought to be encouraging, but when I attempt to print a working text document (e.g. via Gedit) although the printer is listed (along
with IP address and all usual data) it says "Processing - Not
connected?", despite the system clearly knowing the address etc.

Yeah, this should work even without a Web interface and with zero configuration. Or so I thought…

Are you a member of the ‘lp’ group? IIRC printing is only allowed to its members. Try:

    '("wheel" "lp" "netdev" "audio" "video")))

I set the printer up normally in Gnome Print Settings, but if I look at the View Print Queue, it says "Document Print Status: Processing - Not connected?". If I go into Server Settings to check the 'Publish shared printers connected to this system' setting the troubleshooter recommended, I get "CUPS server error: There was an error during CUPS operation: 'Failed to set settings'". Troubleshooting's final verdict
is "There is no obvious solution to this problem."

Heh :-)

As you've probably guessed by now this is due to the read-only configuration file. Only Guix can change CUPS settings through your cups-service-type; not any other helpful programmes.

However, ‘Publish shared printers’ shouldn't need to be on to print from the local host. It controls whether known printers are further advertised to others over DNS-SD. The upstream Boolean ‘Browsing’ (exposed by Guix as cups-configuration's ‘browsing?’) is exceptionally poorly named in this regard.

I'm foxed, and frustrated, and as a desperate work-round I have to ssh
the file to another machine to be printed. By the way, I have
successfully set up printing for MacOS, nixOS, Debian, and Arch, but
GUIX (alone) fails to find the printer, except via the Brother

Thanks for so clearly describing your problem and attempted solutions. Let's hope we can unfox you and get you hooked.

Kind regards,


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]