[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Getting Guix System to use llvmpipe

From: Philip McGrath
Subject: Getting Guix System to use llvmpipe
Date: Tue, 12 Oct 2021 12:52:46 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

Hi folks,

I'm trying to install Guix System on real hardware for the first time, and I'm having some graphics trouble.

The machine has an older Asus M5A78L-M/USB3 motherboard with an onboard Radeon HD 3000 GPU---the R600 family, IIUC, so covered by the `radeon` driver rather than `amdgpu`. I understand that functionality will be limited since I'm not using nonfree firmware, and I can live with that.

I've tried Debian 11 on this board (without "nonfree"), and, after noting the missing firmware, it falls back to work acceptably with `llvmpipe`.

Unfortunately, Guix System is working less well. When it starts the display manager (I've tried both GDM and SDDM, with both X11 and Wayland), the screen goes blank permanently, and the logs show that starting the X server fails: initially with an error about an undefined symbol `exaGetPixmapDriverPrivate`, though through various incantations on the kernel command line or in the X configuration I can produce other errors, like "X: ../include/privates.h:121: dixGetPrivateAddr: Assertion `key->initialized' failed."

Can I configure Guix to give up on the missing firmware and just use `llvmpipe`, as Debian does?

Or, of course, if there's something even better I should do, I'd be glad to hear about that!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]