[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix package: error: unsupported manifest format

From: phodina
Subject: Re: guix package: error: unsupported manifest format
Date: Mon, 01 Nov 2021 21:56:31 +0000

On Monday, November 1st, 2021 at 6:09 PM, phodina via <> wrote:

> Hi,
> I've rebooted my laptop with Guix System installed there and I'm faced with 
> this dreadful message when I attempt to install package with guix package -i 
> PKG:
> guix package: error: unsupported manifest format
> I've tried to do guix pull, which succeeded but I'm still unable to do 
> anything. Also my profile is empty and I have to go to VT as some packages 
> are missing for X session to run.
> What is a proper way to resolve this issue?
> Does it mean there was a change in the format between Guix update and now the 
> old running Guix daemon is unable to read the new format?
> My current Guix version is
> 7af3b822178782d6598865e1d6a780a756dd0cb3

So the issue is solved.

The problem was that the symlink:

ls /var/guix/profiles/per-user/user/guix-profile -al
lrwxrwxrwx 1 user users 20 Nov  1 22:35 
/var/guix/profiles/per-user/user/guix-profile -> guix-profile-85-link

It pointed to a profile, where the contents of file manifest were empty. 
Removing this profile and changing the symlink to the older profile solved the 
problem after relogin.

Though it still make me curious as I don't understand how this could happen.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]