[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Using julia in guix

From: Théo Maxime Tyburn
Subject: Using julia in guix
Date: Tue, 02 Nov 2021 23:55:00 +0100
User-agent: mu4e 1.6.6; emacs 28.0.60

Hello guix people and julia users!

I started using julia in one of my university projects and I am not sure
how this should be done the guix way. Has someone experience with this ?

For know I just used the julia package manager and the packages are in
~/.julia. I was not able to use the guix packages for julia
however. Should something be done manually to tell julia where to find
its packages ?

I encountered two problems. The first with the package "GR" the
second with the package "GLFW". I encountered these bugs while trying
the packages "Plots" and the "GLMakie" backend of "Makie"

The GR bug:
> julia> using GR
> julia> histogram(randn(10000))
> env: 
> ‘/home/teddd/.julia/artifacts/b5fea2b0d5c84336f26b139587a84ee7e8ca2e12/bin/gksqt’:
>  No such file or directory
> connect: Connection refused
> GKS: can't connect to GKS socket application
it then exits because of a segmentation fault.

I tried running the above inside this shell
> guix shell gr-framework
but the result is the same.

The GLFW bug:
> julia> using GLFW
> julia> GLFW.CreateWindow(300,300, "Test")

I also tried running this into
> guix shell mesa glfw mesa-utils libglvnd
with exact same result.

Also I was able to compile and run a minimal GLFW C code so I think my
glfw and mesa installs are fine.

I am not sure these two errors are related but I have the
impression they both come from the fact that guix doesn’t allow the
access to some libraries or binaries the julia packages expect to
find. Please correct me if I am wrong.

Has someone an idea how I could investigate what is going wrong ?

Kind Regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]