[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: packages won't pass white space linting -- what am I doing wrong?

From: Julien Lepiller
Subject: Re: packages won't pass white space linting -- what am I doing wrong?
Date: Fri, 12 Nov 2021 06:52:09 -0500
User-agent: K-9 Mail for Android

Hi, it looks like the linter is correct: there is a tab at the beginning of the 
lines 31, 32 and following. We don't use tabs for identation, please replace 
them with spaces as suggested by the linter :)

Le 12 novembre 2021 02:02:17 GMT-05:00, Blake Shaw 
<> a écrit :
>hiya guix,
>I have a set of packages ready to send upstream, but I can't seem to
>to get them to pass tabulation tests in the linter. as an example, I
>here is the package notcurses which builds and installs fine, yet while
>I wrote it using `guix-devel-mode` in emacs and its thus indented
>accordingly, when I lint it I get:
>error: TODO:: unbound variable
>hint: Did you forget a `use-modules' form?
>~/src/rml/unguix/notcurses.scm:31:0: notcurses@2.4.9: tabulation on line 31, 
>column 0
>~/src/rml/unguix/notcurses.scm:32:0: notcurses@2.4.9: tabulation on line 32, 
>column 0
>[...] ;;and so on for each line until the end of the file.
>the package definition is available here:
>while it appears to look like other package definitions, I can't seem to
>figure out what the issue is. I tried disabling lispy-mode, a paredit
>like emacs mode, re-tabulating and linting again, but it produce the
>same result.
>could this perhaps be a bug in the linter?
>“In girum imus nocte et consumimur igni”

reply via email to

[Prev in Thread] Current Thread [Next in Thread]