[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Running Out of Inodes

From: Jaft
Subject: Re: Running Out of Inodes
Date: Sun, 14 Nov 2021 18:47:54 +0000 (UTC)

 Heh, – well – I tried the large_dir suggestion in that thread and GRUB had the 
same freak-out (in retrospect, not surprising as the E-mails are only from 
2020; dunno why I thought I'd seen 2017, on first read…).
I remember, when first trying to look into this, seeing someone say, "This is 
why I always use Btrfs for my /gnu/store partition," so maybe that's my best 
Out of curiosity, I read that Btrfs requires periodic fragmentation; how often 
do you find yourself doing it and do you use any particular program for it (if 
you don't mind sharing, of course; I know it's not directly Guix related)?
Jonathan    On Sunday, November 14, 2021, 07:47:23 AM CST, phodina 
<> wrote:  
 Hi Jonathan,

On Nov 14, 2021, 12:14 PM, Jaft via <> wrote:
Hey, hey.
It could very well be my own ignorance about things but I'm running into an 
issue that I wouldn't think I'd run into so naïvely; if there's any further 
light to be shed, I very much appreciate it.
I wanted to try out Guix so I installed it to a laptop I have; the previous 
distro I had on there had been using a root partition of about 46G so I just 
decided to keep the same partition setup (though reformatting each one).
About 17 packages in, I started getting a "No space left on device" error; 
looking closer at it, – while I still had ~20% of free disk space available – I 
was fresh out of free inodes. I remembered that someone I'd read, somewhere, 
had said you'd probably want, at least, 50G for Guix so I figured I probably 
shot myself in the foot with so small a root and just opted to reinstall.
This time, I deleted the home partition and the root one to create one 156G 
partition for the entire install and figured that'd be sufficient (I've been 
using ext4 for these, in case that information is relevant, any).
This time, though, I managed 21 packages before running into the same issue.
There's still 70% of the disk space free but I'm entirely out of free inodes; 
leastwise, I was but I tried a guix gc, just to see what all got freed up, and, 
now, I have 5% of all inodes free.
Is this relatively typical? I figured I hadn't done anything particularly out 
of ordinary usage (Guix's new to me so I literally just did an install and then 
started installing packages from the gnu channel).
Let me know if there's any further or more particular info. to include, if 
that'd help; I just wouldn't know what to provide.

You might check this thread [1] as it's similar question. Unfortunately I'm 
running on btrfs.

Hope it helps!

Kind regards


reply via email to

[Prev in Thread] Current Thread [Next in Thread]