[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installing Guix System on Honeycomb LX2 (aarch64)

From: Ricardo Wurmus
Subject: Installing Guix System on Honeycomb LX2 (aarch64)
Date: Wed, 24 Nov 2021 17:36:01 +0100
User-agent: mu4e 1.6.10; emacs 28.0.50


I’m trying to install Guix System on three aarch64 machines that are supposed to join the build farm. I followed the instructions at [1] to boot and flash Ubuntu onto the SSD. Then I installed Guix with the installer script at

And then I tried installing a honeycomb system with the attached module for the maintenance.git repository.

Attachment: honeycomb.scm
Description: Binary data

The system definition looks like this

--8<---------------cut here---------------start------------->8---
(use-modules (sysadmin honeycomb))
(honeycomb-system "pankow"
                 #:wireguard-ip "")
--8<---------------cut here---------------end--------------->8---

And I attempt to build the system with

  guix system build -L modules my-system.scm

from within the ‘hydra‘ directory of the maintenance checkout. Unfortunately, I’ll eventually always run into this error:

  guix system: error: cloning builder process: Invalid argument

I already tried using a more recent daemon, but to no avail. I worked around this by running the daemon with “--disable-chroot”, but that’s not great.

Is this a bug? What can I do to get around it without having to disable the chroot feature?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]