[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Howddya specify max supported dependency version for a package?

From: Jacob Hrbek
Subject: Howddya specify max supported dependency version for a package?
Date: Sun, 16 Jan 2022 07:03:53 +0000

(define-public qbittorrent
    (name "qbittorrent")
    (version "4.2.5")
       (method git-fetch)
       (uri (git-reference
             (url "";)
             (commit (string-append "release-" version))))
       (file-name (git-file-name name version))
        (base32 "1n613ylg6i9gisgk0dbr2kpfasyizrkdjff1r8smd4vri2qrdksn"))))
    (build-system gnu-build-system)
       (list (string-append "--with-boost-libdir="
                            (assoc-ref %build-inputs "boost")
       #:modules ((guix build gnu-build-system)
                  (guix build qt-utils)
                  (guix build utils))
       #:imported-modules (,@%gnu-build-system-modules
                           (guix build qt-utils))
       (modify-phases %standard-phases
         (add-after 'install 'wrap-qt
           (lambda* (#:key outputs inputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (wrap-qt-program "qbittorrent" #:output out #:inputs inputs))
     (list pkg-config qttools))
     `(("boost" ,boost)
       ("libtorrent-rasterbar" ,libtorrent-rasterbar)
       ("openssl" ,openssl)
    ;; NOTE(Krey): Max supported version declared in
       ("python" ,python-wrapper)
       ("qtbase" ,qtbase-5)
       ("qtsvg" ,qtsvg)
       ("zlib" ,zlib)))
    (home-page "";)
    (synopsis "Graphical BitTorrent client")
     "qBittorrent is a BitTorrent client programmed in C++/Qt that uses
libtorrent (sometimes called libtorrent-rasterbar) by Arvid Norberg.

It aims to be a good alternative to all other BitTorrent clients out there.
qBittorrent is fast, stable and provides unicode support as well as many
    (license l:gpl2+)))

I am trying to make a patch to fix which is caused by us using an unsupported python version -> How can i specify that the package is only allowed to use python 3.2 <= 3.5.0 ?

Jacob Hrbek

Attachment: publickey - - 1677db82.asc
Description: application/pgp-keys

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]