[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Howddya specify max supported dependency version for a package?

From: Julien Lepiller
Subject: Re: Howddya specify max supported dependency version for a package?
Date: Sun, 16 Jan 2022 09:46:53 +0100
User-agent: K-9 Mail for Android

Simple unhelpful answer, you can't. Guix doesn't work like that. We don't 
specify package range or give a package any way to choose itt dependencies. 
When you specify a dependency, it's always a reference to a very specific 
packaqe (though the reference might evolve with newer guix revisions). It 
simplifies package management since there's no constraint solving or anything 
of the sort.

For your problem I see two potential solutions: fix the package to allow our 
current python version, though there might be a reason why it's not allowed, or 
package python 3.5 and use it instead of the current python version.


Le 16 janvier 2022 08:03:53 GMT+01:00, Jacob Hrbek <> a 
écrit :
>(define-public qbittorrent
>   (package
>     (name "qbittorrent")
>     (version "4.2.5")
>     (source
>      (origin
>        (method git-fetch)
>        (uri (git-reference
>              (url "";)
>              (commit (string-append "release-" version))))
>        (file-name (git-file-name name version))
>        (sha256
>         (base32 "1n613ylg6i9gisgk0dbr2kpfasyizrkdjff1r8smd4vri2qrdksn"))))
>     (build-system gnu-build-system)
>     (arguments
>      `(#:configure-flags
>        (list (string-append "--with-boost-libdir="
>                             (assoc-ref %build-inputs "boost")
>                             "/lib")
>              "--enable-debug"
>              "QMAKE_LRELEASE=lrelease")
>        #:modules ((guix build gnu-build-system)
>                   (guix build qt-utils)
>                   (guix build utils))
>        #:imported-modules (,@%gnu-build-system-modules
>                            (guix build qt-utils))
>        #:phases
>        (modify-phases %standard-phases
>          (add-after 'install 'wrap-qt
>            (lambda* (#:key outputs inputs #:allow-other-keys)
>              (let ((out (assoc-ref outputs "out")))
>                (wrap-qt-program "qbittorrent" #:output out #:inputs 
>              #t)))))
>     (native-inputs
>      (list pkg-config qttools))
>     (inputs
>      `(("boost" ,boost)
>        ("libtorrent-rasterbar" ,libtorrent-rasterbar)
>        ("openssl" ,openssl)
>     ;; NOTE(Krey): Max supported version declared in 
>        ("python" ,python-wrapper)
>        ("qtbase" ,qtbase-5)
>        ("qtsvg" ,qtsvg)
>        ("zlib" ,zlib)))
>     (home-page "";)
>     (synopsis "Graphical BitTorrent client")
>     (description
>      "qBittorrent is a BitTorrent client programmed in C++/Qt that uses
>libtorrent (sometimes called libtorrent-rasterbar) by Arvid Norberg.
>It aims to be a good alternative to all other BitTorrent clients out there.
>qBittorrent is fast, stable and provides unicode support as well as many
>     (license l:gpl2+)))
>I am trying to make a patch to fix 
> which is caused 
>by us using an unsupported python version -> How can i specify that the 
>package is only allowed to use python 3.2 <= 3.5.0 ?
>Jacob Hrbek

reply via email to

[Prev in Thread] Current Thread [Next in Thread]