[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Stuck at scheme prompt when booting

From: coralgoat
Subject: Re: Stuck at scheme prompt when booting
Date: Sat, 12 Feb 2022 20:15:43 +0100 (CET)

I have some more information to add to my initial message.

I have opened the computer to make sure the hard drive has a good
connection to the motherboard and it does.

I have also tried typing `,bt` at the "scheme@(guile-user)>" prompt
the output is included below.  Note  there is a solid white square 
single character symbol in the output and I am representing it as
 "***" in the output below.

The line in the output that catches my attention is:
"1 (copy-file "/etc/static/resolv.conf" "/etc/resolv.conf")"
This catches my attention because I took this computer to second
location where I tried connecting to a WiFi network.  I was getting
domain name resolution errors and was not able to connect to the
internet.  I resolved the domain name resolution errors by doing 2
1) editing /etc/resolv.conf changing it to a single line that set a
   specific nameserver
2) I ran this command `chattr +i /etc/resolv.conf`
After doing these two things the internet connection was okay.

When I was done in the second location I powered off the computer
and moved to a third location and when it tried to turn on the
computer in the third location I was stuck at this scheme prompt.

I think that if I ran the command `chattr -i /etc/resolv.conf` it
might fix the problem and allow the system to boot however I get an
error when I try typing that at the scheme prompt.

Any suggestions on how I should get a Linux console terminal so I can
enter the `chattr -i /etc/resolv.conf` command?

I could try booting an operating system in memory and then use a disk
encryption program to decrypt the hard drive with my passphrase and
then run `chattr -i /etc/resolv.conf`.  What disk encryption program
should I use to decrypt the hard disk?

Thank you

,bt output:
In gnu/build/linux-boot.scm:
   617:14 9 (_)
In unknown file:
           8 (primitive-load "gun/store/a-long-hash***")
In ice-9/eval.scm:
    619:8 7 (_ #f)
In unknown file:
           6 (primitive-load "gun/store/a-long-hash***")
In srfi/srfi-1.scm:
    634:9 5 (for-each #<procedure primitive-load (_)> _)
In unknown file:
           4 (primitive-load "gun/store/a-long-hash***")
In srfi/srfi-1.scm:
    634:9 3 (for-each #<procedure 7fd6fc3d1ec8 at gnu/build/activa***> ***)
In gnu/build/activation.scm:
   265:20 2 (_ _)
In unknown file:
           1 (copy-file "/etc/static/resolv.conf" "/etc/resolv.conf")
In ice-9/boot-9.scm:
  1669:16 0 (raise-exception _ #:continuable? _)

Feb 9, 2022, 16:00 by

> I have run into a problem with booting a computer that is running the
> Guix operating system.
> After entering the passphrase when prompted with:
>> Enter passphrase for /dev/sda1:
> I end up at this prompt:
>> scheme@(guile-user)>
> and the system does not continue to boot.
> I have not made any changes to my system configuration to cause this
> issue.
> Below is the sequence that results in me getting the
> "scheme@(guile-user)>" prompt.
> In the output below it says "',q' to continue" but when I do that at
> this prompt I am greeted there is a lot of output with the last line
> of the output saying:
>> ---[ end Kernel panic - not syncing: Attempted to kill init! exit
> >  code=0x00000000 ]---
> Is there something I need to enter at this scheme prompt to continue
> with the booting this computer?
> If there is not a way to continue booting this computer from this
> scheme prompt how should I attempt data recovery from the encrypted
> hard drive?
> Any help with this would be appreciated.
> Thank you
> ---
> 1) I push the power button to power on the system.
> 2) It says:
>> Grub loading..  Welcome to GRUB!  Attempting to decrypt master
>> key...  Enter passphrase for hd0,msdos1
>> (lone-string-hexadecimal-characters):
> 3) I enter the passphrase
> 4) It says: "Slot 0 opened"
> 5) The Grub menu is displayed
> 6) I do nothing and it continues after the grub timer finishes
> counting down.
> 7) These messages are displayed:
>> x86/cpu: VMX (outside TXT) disabled by BIOS ACPI Error:
>> AE_NOT_FOUND, While resolving a named reference package element -
>> 2001 (20201113/dspkginit-440) ACPI Error: AE_NOT_FOUND, While
>> resolving a named reference package element - 2001
>> (20201113/dspkginit-440) GC Warning: pthread_getattr_np or
>> pthread_attr_getstack failed for main thread GC Warning: Couldn't
>> read /proc/stat Welcome, this is GNU's early boot Guile.  Use
>> '--repl' for an initrd REPL.  loading kernal modules...
> 8) Then it prompts me for a passphrase:
>> Enter passphrase for /dev/sda1:
> 9a) If I deliberately enter the wrong passphrase it says:
>> No key available with this passphrase.  Enter passphrase for
>> /dev/sda1:
> 9b) If I enter the right passphrase it says:
>> /dev/mapper/cryptroot: recovering journal
>> /dev/mapper/cryptroot: clean, #/# files, #/# blocks
>> loading '/gnu/store/hash-system/boot'...
>> making '/gnu/store/hash-system' the current system.
>> .
>> setting up setuid programs in '/run/setuid-programs'...
>> populating /etc from /gnu/store/hash-etc...
>> ice-9/boot-9.scm:1669:16: In procedure raise-exception: In procedure
>> copy-file: Operation not permitted
>> Entering a new prompt. Type ',bt' for a backtrace or ',q' to
>> continue.
>> GNU Guile 3.0.2 Copyright (C) 1995-2020 Free Software
>> Foundation, Inc.
>> Guile comes with ABSOLUTELY NO WARRANTY; for details type ',show w'.
>> This program is free software, and you are welcome to redistribute
>> it under certain conditions; type ',show c' for details.
>> Enter ',help' for help.
>> scheme@(guile-user)>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]