[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guixsd boot stop

From: Martin Castillo
Subject: Guixsd boot stop
Date: Fri, 18 Feb 2022 17:48:00 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.6.0


I installed guixsd 1.3.0 inside qemu with efi. (On this list: "Create new EFI guixSD installaton from existing bios guixsd installation") That worked (though I noticed some problems inside the install process) and booted. I then put the harddrive into a real machine (Asus X73B). It could not find the boot data and started the uefi setup. I then put the guixsd 1.3. image onto a usbdrive and booted that. I followed the graphical installer until network was set up. Then switched to console:

mount /dev/sda3 /mnt
mount /dev/sda1 /mnt/boot/efi
cd /mnt
mount --bind /dev dev
mount --bind /sys sys
mount --bind /proc proc
chroot /mnt /bin/sh
echo nameserver >/etc/resolv.conf # NetworkManager inside qemu created a now invalid resolv.conf. fix that
# my user had an up to date guix, so I used that
/home/mcd/.config/guix/current/bin/guix-daemon --build-users-group=guixbuild --substitute-urls &
/home/mcd/.config/guix/current/bin/guix system reconfigure /etc/config.scm

(There should be an official, documented way to chroot into a guixsd system!)

At the end of the installation I ran guix system build /etc/config.scm and got 2 dmesg lines about missing firmware [1]:
0000:03:00.0: Missing Free firmware (non-Free firmware loading is disabled)
r8169 000:03:00.0: Unable to load firmware /*(DEBLOBBED)*/ (-2)

I ignored it and rebooted. No it is stuck [1] just like in <>.

Even AltGr+SysRq+REISUB does not work.

I know you cannot recommend unfree software, but I'd like to use that machine instead of throwing it away, even if I need some binary blobs.
How can I install the necessary firmware?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]