[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Android Device Mounting Detection with GVFS Help

From: Jaft
Subject: Re: Android Device Mounting Detection with GVFS Help
Date: Sat, 26 Feb 2022 22:20:18 +0000 (UTC)

 Hmm; that's unfortunate. I can't say I've noticed any of the other behavior 
(thankfully?) but not recognizing my phone's definitely been an obvious one. 
Heh, I suppose it's all the more disappointing as I seem to've gotten close.
Have you been using an alternative to GVFS (I know some people use udiskie, 
instead)? Or just tolerating the bugginess?
    On Monday, February 21, 2022, 07:08:57 PM CST, raingloom 
<> wrote:  
 On Mon, 14 Feb 2022 11:19:29 +0000 (UTC)
Jaft via <> wrote:

> I dunno if anyone might have any suggestions but I've been trying to
> get my Android phone get detected. I'm using GVFS and Thunar; full
> details of what I originally tried are at
> but the short of it is that I noticed that the 69-libmtp.rules file
> that Guix installs differed from my Debian machine so I added a
> udev-rules-service that added all the devices that were in the Debian
> file and found the device was recognized, now, but trying to click on
> it or mount it still resulted in the error "No mtp devices found."
> Someone on the IRC channel recommended trying android-udev-rules so I
> did; this resulted in the phone not getting recognized, when plugged
> in, by Thunar, again – but it was able to be recognized as a
> connected device by adb. I've attached my system config. file, so
> it's clear to see what the setup I've tried is; I have no idea what
> else to try (if there's anything else even to try) but thanks for any
> help!

GVFS in general seems extremely buggy, but especially on Guix. If you
manage to figure this out I'd be very interested.
Other fun GVFS related issues include:
- sometimes mounts just plain don't show up (no /run/user/$UID/gvfs
- removable drives only show up once you've run fstab --list on them.
  they can be mounted with udiskctl, but they aren't visible in
- incorrect handling of symlinks can lead to data loss, bug has been
  known for years and no workaround or fix exists.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]