[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix home, guix system, channels, some noob questions

From: Julien Lepiller
Subject: Re: Guix home, guix system, channels, some noob questions
Date: Wed, 11 May 2022 12:47:01 +0200
User-agent: K-9 Mail for Android

Hi Sébastien,

When you run guix describe, it's running the guix for your user, which miggt be 
different from the one you run when you use sudo. That could explain why the 
modules are not found. I don't think guix home has anything to do with that.

I noticed that the first time you use sudo -E, whereas you use only sudo on 
step 5. Mayée that's why it fails?

I would run sudo guix describe and sudo -E guix describe to see how the two 
might be different from your user's guix :)


On May 11, 2022 11:09:19 AM GMT+02:00, "Sébastien Rey-Coyrehourcq" 
<> wrote:
>Hi Guix people :)
>I'm starting guix, picking information when needed into documentation.
>I'm facing difficulties with channels.scm since i start using "guix home", i 
>read the doc page, but i need some other things to understand.
>Here my logic to start just after install :
>1 - I modify my //etc/guix/channels.scm/ file to add some modules : /nonguix/ 
>(my computer don't work well without) and /emacs-native-dep/ from flatwhatson 
>flat channel.
>2 - I /guix -E guix system reconfigure /etc/config.scm/, /guix pull/, and 
>everything goes well
>3 - Like explained in the doc, I run /guix home import ~/src/guix-config /that 
>generate /a //home-configuration.scm//
>/4 - /Into /home-configuration.scm///i add the package htop and 
>5 - In the guix home doc the next command is /guix home reconfigure config.scm 
>/but this is probably a typo and i run /guix home reconfigure 
>6 - Everything goes well, emacs-native-dep compile during 1 hour, problems 
>arrive after that.
>7 - I'm moving the //etc/guix/config.scm/ and //etc/guix/channels.scm /to my 
>home /~/.config/guix/ , /and i run /sudo guix system reconfigure 
>~/.config/guix/system.scm///*, that fail*/, /it seems the module (nongnu and 
>emacs-native-dep) are not referenced, like the error say /"no code for module 
>( nongnu ..." /But when i run /guix system describe/, the corresponding 
>channel are well defined. /
>After that, i try many thing, like moving channels.scm and system.scm back to 
>/etc/guix/ but every reconfigure command fail in link with channel/module not 
>recognized (emacs-native-dep or nongnu)
>- /guix home reconfigure ~/src/guix-config/home-configuration.scm/
>- /guix system reconfigure ~/.config/guix/system.scm/
>- /guix system reconfigure ~/etc/guix/config.scm/
>So my question is first, why that fail after switching to guix home ? and how 
>and where i need to define/set correctly the /channel.scm/ file to repair that 
>For example, /guix system//describe/ and /guix home describe/ and /guix 
>describe/ return all different channel referenced, how i manage that ?
>I suppose there is a "workflow to use well guix home"? but this is not 
>actually in the doc. For example, perhaps after creating and switching to guix 
>home profile, running guix system is impossible or prohibited ? I suppose this 
>will be added in the future.
>Thanks a lot for your help.
>Sebastien Rey-C

reply via email to

[Prev in Thread] Current Thread [Next in Thread]