[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

LiveUSB stuck at GRUB welcome screen

From: Iannetta Paul
Subject: LiveUSB stuck at GRUB welcome screen
Date: Fri, 20 May 2022 07:54:28 +0200
User-agent: Roundcube Webmail/1.2.7

Hi Guix,


I seem unable to make GRUB work and would like to know whether it is possible to generate an image that would use extlinux/syslinux instead.


I am trying to install guix on a pretty old box (an HP Pavilion dv6000 series from circa 2010) with no efi support. I've been running funtoo on it for the last 5 years or so and everything is okay, the bootloader is GRUB.

At first, I tried to surgically snipe (by overwriting) the `grub.cfg` on the iso (directly with dd and the offset of grub.cfg on the iso) to not use gfxmode, to no avail. The file was properly overwritten but it seemed to not be sufficient.

Secondly, I installed the package manager guix on funtoo and tried to create an image myself. That proved more tricky than I expected because since guix is running on a foreign distro there is no initial system configuration... and doing `guix system image -t iso9660 install.scm` fails by telling you that there is no file `install.scm` even though the file is in the current directory.

From that point, I looked up (with `locate`) the location of `install.scm` files on my system, and there was a couple in /gnu/store/xxx-guix/.../gnu/system/, I used the one which looks like this ( ). After some fiddling (some deprecated syntax (targets instead of target) and missing fields (missing description here [1]), the part with the loopback required an `addresses` field, etc.) It worked to create an image, but it was still grub.

I tried replacing `grub-bootloader` on line 455 by `extlinux-bootloader` and added `#:use-module (gnu bootloader extlinux)` at the top of the file. I could generate an image from that file but as before the bootloader was still grub.

At that point, I tried the various options of grub to modify the gfx resolution (I suspect that grub fails to find the correct resolution of my screen and stops at the welcome screen), it worked and was reflected in the `grub.cfg` of the image. Nevertheless, the boot did not proceed any further :(

I would really like to try building an image with syslinux/extlinux to see whether I can go further but I am currently stuck now. I've read this page [2] but it is still unclear. The generation with the `pine64.scm` file works fine but not with my custom file (guix system complains it does not exist, and the most surprising is that if I copy past the content of my custom file into the `pine64.scm`, the `pine64.scm` file is reported missing...)

The last solution would be to overwrite my current distribution by guix and replace the init system by shepherd.




Iannetta Paul
ENS de Lyon

reply via email to

[Prev in Thread] Current Thread [Next in Thread]