[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

nvme0n1p1 (NVME/M2/SSD) boot device recovery

From: yasu
Subject: nvme0n1p1 (NVME/M2/SSD) boot device recovery
Date: Sat, 21 May 2022 16:15:53 +0900
User-agent: Evolution 3.42.1


I have just had a horrible experience of my Asus motherboard (TUF
GAMING X570-PLUS) suddenly not booting...The NVME device (CSSD-
M2B05GPG2VN) was no longer availalbe on the list of bootable devices
from BIOS menu of the motherboard.

I still don't know exactly what happened but my suspicion is that
something triggered the 'reset' of the motherboard (may have been that
the cr2032 battery went bad?  I replaced it)

Here is what I did to solve it:

- I downloaded SystemRescue , created a
USB thumbdrive boot device.

- After booting from it, I ran
  efibootmgr -c -d /dev/nvme0n1p1 -p 1 -L "Guix" -l

- Finally, I was able to select the NVME boot device.

It seemes that onboard ethernet (Probaly RealTek) completely died at
the same time... I tried various BIOS recovery procedure such as
triggeron ON/OFF of LAN from Bios Settings screen, updating to the
latest BIOS, etc, - none of it worked.   So I am using a USB3.0
Ethernet Adaptor right now.

I hope this memo will be of use to someone in the future!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]