[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix Halts After "updating substitutes from …"

From: raingloom
Subject: Re: Guix Halts After "updating substitutes from …"
Date: Wed, 25 May 2022 01:22:31 +0200

On Tue, 24 May 2022 17:55:20 -0500
"Wamm K. D." <> wrote:

> Hey, hey; 'not sure what caused this but my ~guix~ command suddenly
> started getting stuck, when I do a pull or try to install a package,
> after
> > substitute: updating substitutes from ''...
> > 100.0%  
> I haven't let it run for longer than an hour but it just sits there
> and doesn't progress any further. When I run ~guix upgrade~, it halts,
> similarly, after listing which programs it's going to upgrade.
> Anyone, possibly, know what this is (or, at least, how I might get
> around it)?
> Thanks for any help!

For some quick diagnostics maybe you could try running it with strace,
or attaching strace to the running process to see if it's stuck on a
system call or if it's some kind of deadlock or livelock or other
concurrency related fun.
Actually... I thiiink I've experienced a hang like this on my i686
machine, but aborting it and running pull again fixed it.
Does it happen always?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]