[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Milan Svoboda
Subject: SweetHome3D
Date: Sat, 18 Jun 2022 23:05:15 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.10.0


I am trying to run SweetHome3D. I used it on NixOS and it worked without any issue,

here I tried to mimic variables and flags used on NixOS, but it doesn't work. It requires old version of JDK/JRE, therefore icedtea@3 is used here...


MESA_GL_VERSION_OVERRIDE=2.1 LD_LIBRARY_PATH="$(printf '%s/lib:' $(guix build --no-grafts libx{11,xf86vm,render} mesa icedtea@3))$LD_LIBRARY_PATH" java -Dsun.java2d.opengl=true -jar /tmp/SweetHome3D-6.6.jar


It looks to me like icedtea@3 is missing something that should be there...


Caught AppContextInfo(Bug 1004) InaccessibleObjectException: Unable to make public static sun.awt.AppContext sun.awt.AppContext.getAppContext() accessible: module java.desktop does not "exports sun.awt" to unnamed module @5a2e4553 on thread J3D-Renderer-1     [0]: java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(Unknown Source)


Any idea what is wrong here? I am not very knowledgeable in Java land.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]