[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Coreboot,T440P & GUIX installer

From: Wil deBeest
Subject: Re: Coreboot,T440P & GUIX installer
Date: Thu, 23 Feb 2023 10:48:28 +0100 (GMT+01:00)

22 Feb 2023 18:35:03 jerome moliere <>:

> Hi all,
> I just bought a refurbished machine (T440P) with Coreboot to run a fully
> open source experience...
> Experience is not so good for the moment, because I am stuck in the third
> or fourth screen of the GUIX installer during network detection.
> My laptop has an atheros wifi  chipset  supported for a long time by the
> Linux kernel (no proprietary firmware)... This wifi chipset is recognized
> but activating it fails during ESSID pairing (bad password)...
> T440P has an ethernet connector, ethernet card is recognized too , the card
> works on console during installation (ip a shows correct information, ping
> works nicely inside my LAN or for public domains)  but network step finish
> with RED screen saying my network is unable to provide access to
> substitutes  (git repos for GUIX ?) while github is resolved in console...
> I have tried to restart the network services, to play with conmanctl to
> restart services, rescan... But it always fails!!!
> I wondered if someone runs Coreboot with GUIX ? The machine is quite old so
> all hardware is recognized, wifi chipset is compliant with free software,
> so it should work nicely ..And I can't think that installer has a so big
> bug (it should prevent many people from installing Guix)..
> I have tried the 1.4 iso & the system crafter latest build but same
> result...
> Have you any idea...
> thanks for sharing
> -- 
> J.MOLIERE - Mentor/J
Hi Jérôme,

I am running Guix on a Lenovo X220 tablet with osboot (  I don't 
know how to help you, but if you have an idea or if you need me to check 
something, I can try and do that.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]