[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Mysteries of channel configuration during system reconfigure

From: Kyle Andrews
Subject: Mysteries of channel configuration during system reconfigure
Date: Thu, 09 Mar 2023 02:50:29 +0000

Dear Guix,

I am trying (and failing) to setup a new computer with Guix. I managed
to get through the installation process with a configuration that boots
into GNOME. However, the keyboard is messed up (I made a typo) and I
don't yet have the desktop environment up and running I actually feel
productive using. GNOME places too many extraneous demands on my
attention. There is a lot going on and I find all the beeping
unsettling. So I am typing this email on my old computer with Guix.

One of the selling points in Guix marketing for me is that the system
configuration should be self contained within /etc/config.scm and
channels.scm. However, this appears to not be the case. There seems a
third element hidden away which prevents me from running:

guix system reconfigure /etc/config.scm

This command errors out:

failed to load '/etc/config.scm'
no code for module ...

At the moment since I am still very early in setting up my new computer,
I have to type everything so I'm not going to go into more detail than
that. Suffice to say it doesn't see the modules I need from the extra
channel. It did see them during the installation otherwise my computer
would be in a far less usable state than it is.

When I run the following command:

guix system describe

The addition channel gets listed. How can it be listed yet be unknown to
the `guix system reconfigure` command?

During the installation of my new computer I used guix pull -C
/etc/channels.scm. I was struggling with the official documentation, so
this was kind of an improvisation. Could doing this nonstandard action
have lead to this nonstandard state? Can it be fixed? 

I tried running the commands with the root user and with prefixing
sudo. Neither variat produces the desired result: a new configuration
with the correct keymap and my next steps towards setting up my desktop

Thanks in advance for your help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]