[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Too many levels of symbolic links

From: Roman Scherer
Subject: Re: Too many levels of symbolic links
Date: Tue, 14 Mar 2023 20:16:52 +0100
User-agent: mu4e 1.8.13; emacs 29.0.60

Felix, I'm back on track! I found what triggered this horrible problem :)

At some point I added the qemu-binfmt-service-type to my system. I
copied a snipped from the manual and finally "adjusted" it to this:

(define %qemu-service
  (service qemu-binfmt-service-type
            (platforms (lookup-qemu-platforms "aarch64" "x86_64")))))

I don't know much about quem and I thought, well let's choose the
"aarch64" and "x86_64" qemu platforms on which I run Guix, and maybe
re-use this service on multiple machines.

My Guix system runs on the aarch64 architecture. It turns out that
having "aarch64" in lookup-qemu-platforms causes the "Too many levels of
symbolic links" error. As soon as I remove it, everything is good again.

Now, maybe it does not even makes sense to add "aarch64" to that list,
but I think it should not fail that catastrophical. I still don't know
which symlink was causing this issue, though.

That's where I am. Just happy that I survived my first serious Guix
crash. :)

Thanks for your help so far,


Felix Lechner <> writes:

> Hi Roman,
> On Fri, Mar 10, 2023 at 7:32 AM Roman Scherer
> <> wrote:
>> Right now I rolled back to generation 53, which is still
>> working.
> Great!
>> Is it correct to look for the problematic files in the directory to
>> which system-54-link links to?
> Yes, probably. Unfortunately, profiles are large bundles of symbolic
> links, so finding the offending cycle may not be easy.
>> Generation 54 is the broken one, which does boot up, but
>> logging in fails with the too many levels of symbolic link issue.
> Since the issue occurs at login, there may also be a bad interaction
> with your user profile. What if you log in as another user?
>> I run the problematic commands from that directory and they seem to run
>> from the non-broken system
> My prime list of suspects include something like a system-wide Bash
> profile (or whichever shell you use).
>> I'm thinking of re-installing my system completely.
> Please don't do that. It is not necessary.
> Instead, you can delete generation 54 and try again. Make sure to
> 'guix pull' before reconfiguring again.
>> Do I have any other option, even an unsupported one?
> Please post the config.scm for your generation 53, plus a diff to
> generation 54. You find copies via 'guix system describe'. It may also
> be helpful to attach your home.scm, if you use Guix Home.
> Together with the changes in Guix since the commit on which generation
> 53 is based, we will find the issue. The process is more or less
> deterministic.
> Please keep up hope. All needed software is already installed. Guix
> has extraordinary ways to recover—even though they can be hard to
> figure out.
> Kind regards
> Felix

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]