[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Set up the bluetooth - error : dbus-service-type: unbound variable

From: Mario Forzanini
Subject: Re: Set up the bluetooth - error : dbus-service-type: unbound variable
Date: Fri, 17 Mar 2023 13:43:23 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.7.2

On 3/17/23 1:39 PM, wrote:
Hi Mario !

Thanks you for your help, it worked!
Taking care to disable my old statements, I simply inserted your lines into my 
After rebooting, I was pleased to see the bluetooth enabled.
For my test, I use a mini bluetooth speaker M-370 DJ. I detect it in the 
blutooth settings of Gnome.
Its configuration does not succeed but it is another problem, I will see that...

Your solution to have the bluetooth activated is simple and effective, again, 
thanks a lot!


I'm happy to hear that.

I responded at 4AM and forgot to add the mailing list in Cc, I will include my response below in case anyone else has similar problems in the future.

----- Mail original -----
De: "Mario Forzanini" <>
À: "hub lombard" <>
Envoyé: Vendredi 17 Mars 2023 03:37:21
Objet: Re: Set up the bluetooth - error : dbus-service-type: unbound variable


On 3/16/23 9:20 PM, wrote:
Wanting to use bluetooth devices, especially audio speakers, I have tried to
inser in my /etc/config.scm some relevant gnu packages, modules, services...
But I can't make it work
$ sudo guix system reconfigure /etc/config.scm
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
erreur : dbus-service-type : variable non liée

I think the service you are looking for is called
'dbus-root-service-type', rather than 'dbus-service-type', but I'm
pretty sure it is part of %desktop-services anyway.

After have put '(gnu packages dbus)'

$ sudo guix system reconfigure /etc/config.scm
guix system: erreur : échec lors du chargement de « /etc/config.scm » :
ice-9/boot-9.scm:3330:6: In procedure resolve-interface:
no code for module (gnu packages dbus)

I don't know how to investigate more...
Thank you in advance if you have some infos :)



This is my working bluetooth configuration

(use-modules (gnu services base)
               (gnu services desktop))

    ; ...
         (service bluetooth-service-type
                   (auto-enable? #t)))

DBus starts by default and bluetooth is enabled and automatically
configured, Pulseaudio can connect to my bluetooth headset out of the
box. Sometimes I had issues with bluetooth on GNU/Linux because I didn't
realize my antenna was software locked and I needed to unlock it with
rfkill. I hope this helps

reply via email to

[Prev in Thread] Current Thread [Next in Thread]