[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Identifying cause of local package build

From: Skyler
Subject: Re: Identifying cause of local package build
Date: Tue, 23 May 2023 19:36:25 +0000

Thank you for the replies! The `guix refresh --list-transitive` command was 
helpful for what I was trying to do, although I now think I was going down the 
wrong path.

While checking things in my system, I noticed that the guix command that was 
invoked under a root shell pointed to a different binary than under my user's 
shell. I assumed that having different versions of guix simultaneously 
operating on the same store could cause lots of problems which are difficult to 
explain, so I decided to reinstall the system from scratch, which did not seem 
too troublesome since guix's commitment to declarative configuration makes 
re-installation very easy. I had some issues where I saw error messages similar 
to, which was speculated to be due to 
difficulties communicating with the server. So I just waited a few days each 
time this happened and re-tried, and eventually I got the bare-bones config 
from the installer ISO to install to my machine.

However, I am still seeing a similar problem to before, when I try to `guix 
home reconfigure` the process starts building git-minimal. I stopped it 
immediately instead of waiting to see how far it got because this seemed to be 
the same behavior. I also found that `guix repl` produces an error that the 
__libc_pthread_init symbol is undefined in, although readelf 
tells me that the symbol exists. The symbol value is null which seems weird but 
I don't spend a lot of time looking at readelf output and every symbol in the 
'.rela.plt' section has a null value, so maybe this is expected. The error 
occurs if I run guile without any arguments, from the guile-wrapper used by 
guix. Running the system guile command works fine.

Also, the error only occurs in the guix from `~/.config/guix/current/bin/guix`. 
This runs by default because it is in my path first, but if I run 
`/run/current-system/profile/bin/guix repl` then the program executes without 
issue. I'm not sure if the one in /run is an older version that I shouldn't use 
or if it's the one that I should be getting when I run plain guix (without a 
path). IIUC, `guix pull` is supposed to update the files in 
`~/.config/guix/current` to be the correct ones, and the guile-wrapper is 
pointing to an absolute path of libpthread in the store as it should, so I'm 
not sure how this error is occurring. The system has not changed much from the 
bare-bones config, I just added tmux, vim, and nss-certs to make the TTY easier 
to use and make sure I could download https urls.

This seems strange. I'm going to keep looking into this, but hoping that 
something above might sound familiar to someone.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]