[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot run virt-manager as my user

From: Robby Zambito
Subject: Re: Cannot run virt-manager as my user
Date: Mon, 29 May 2023 13:06:35 -0400
User-agent: mu4e 1.10.2; emacs 28.2

David Conner <> writes:

> I have a similar libvirtd service configuration on my system, but I've
> only used libvirt a handful of times. Do you want access to the user's
> libvert socket?

I have no strong preference towards using a user-specific libvirt socket
versus the system libvirt socket, as I'm running this on my single user

> If you run =libvirtd --help= this tells you where the user session
> socket will be set up.
> I tried using =virsh -c qemu:///session=

This worked the same as `virsh -c qemu:///system` for me (as which one
doesn't really matter to me), and it gave me the idea to try using
/session in virt-manager instead. In virt-manager I went to File > Add
Connection..., set the hypervisor to Custom URI... and set the URI to
qemu:///session like you said.

This worked! I'm not sure why I can't use the system one, but this is
good enough for me :). I'm also not actually sure why this works, since
I don't have the socket file shown by `libvirtd --help`...

Oh well :D good enough for me!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]