help-guix
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

git-fetch recursive error


From: Lucy Coleclough
Subject: git-fetch recursive error
Date: Mon, 2 Oct 2023 14:17:54 +0100

Hi there, my name is fi

I am writing to obtain help with an issue that has been occuring for about
4 days
Upon building a custom package definition which uses the git-fetch source
obtenance method and has the `recursive?` flag set to `#true` the fetch
fails seemingly due to the build environment being unable to find certain
program-s.

A file I have been using to test this is named `test.scm` and the content-s
are found here: https://paste.debian.net/1293802/ `test.scm`
Upon running this file with `guix build -L. test` on my current system, the
following output is produced: https://paste.debian.net/1293803/
`ErrorOutput`

Of note is that this test package did build on the installation system that
I use, before pulling the latest guix and after.
It also sucseeded on the target machine directly after install, it
sucseeded on the target machine after pulling the latest guix, then it
failed after reconfiguring my system using my custom config and ever since
my config is programmatically constructed but a flattened version is as
follows: https://paste.debian.net/1293805/ `FullFlatenedSystem.scm`
I have tried peeling my system definition back to a very bare one to see if
I can find a state where some problamatic element was removed but I had no
luck, all system generation-s posed the same issue
I also tried building these generation-s with solely the channel-s needed
to create them but this did not work
The most minimal system definition i used was this:
https://paste.debian.net/1293806/ `MinimalFlatenedSystem.scm`


The current item that this is blocking for me is packaging the latest glib
commit from main.
The submodule needs to be downloaded or else `meson setup` fails as there
is an empty wrap
I have tried invoking `program-file` in a gexp in a build stage and in the
fetch snippet but both attempt-s leave me unable to include `( guix gexp)`
I have tried including it in `origin`~s `modules` field, I have also tried
( `with-imported-modules` with and without `source-module-closure`) but to
no avail
When I conduct a local build of glib, `meson setup` fetches the submodule-s
then however this does not occur during the configure stage of my meson
build system package

I am unsure how to structure these request-s and I realise someone must
spend their time in order to answer this, I admit, i am flailing baby
Is the issue relating to git-fetch recursive a known issue, I have not seen
it on the issue tracker? but I want to check that I am not doing anything
wrong first
Is it true that one can not use arbitrary function-s in the origin snippet
and in the build stage-s?
Is it true that internet access during build is limited by default to the
fetch component?
And if so is there a method to allow internet access to other component-s?

Thank you for reading

Attachment: test.scm
Description: Text Data

Attachment: ErrorOutput
Description: Binary data

Attachment: FullFlatenedSystem.scm
Description: Text Data

Attachment: MinimalFlatenedSystem.scm
Description: Text Data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]