[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix Home: SSH won't ask for GPG password

From: Maxim Cournoyer
Subject: Re: Guix Home: SSH won't ask for GPG password
Date: Fri, 06 Oct 2023 08:53:50 -0400
User-agent: Gnus/5.13 (Gnus v5.13)

Hi Caleb,

Caleb Herbert <> writes:

> Maxim Cournoyer <> wrote ..
>> I now use the canonical 'pinentry' package, which seems most featureful.
> Changed to plain "pinentry".
> (service home-gpg-agent-service-type                         
>                   (home-gpg-agent-configuration                       
>                    (pinentry-program                                  
>                     (file-append pinentry "/bin/pinentry"))           
>                    (ssh-support? #t)))
> I still get an error when trying to reconfigure. 

What do you mean by "still" ?  It must have worked at some point?  What
changed in your configuration?

> Loading /gnu/store/2hwp7i1xn24rlsnwmcc8hpbdynznv4an-shepherd.conf.
> herd: error: exception caught while executing 'load' on service 'root':
> In procedure fport_write: Input/output error
> Comparing 
> /gnu/store/3jphbp9sisp54nshd8dimrnn4lks3p4d-home/profile/share/fonts and
> /gnu/store/vkkl9ymxkcq5a72z42rm4yx573k0wk1f-home/profile/share/fonts... done 
> (same)
> Evaluating on-change gexps.
> On-change gexps evaluation finished.

Hm.  I'm not sure what that is trying to say, other than there was some
error in the service definition.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]