[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot run Docker container

From: Caleb Herbert
Subject: Cannot run Docker container
Date: Sun, 10 Dec 2023 12:24:30 -0600

Hi Guix,

I can't get a Docker container to work.  I'm trying to use the program
Thumbsup, which is a lousy JavaScript program.  I wrote a wrapper script
to run the container.

#!/usr/bin/env -S guile --no-auto-compile -e main -s # -*- Scheme -*-
;; thumbsup - Run Thumbsup from container
(define (main args)
   (string-append "docker run " "-t "
                  "-v " (getcwd) ":/work "
                  "-u " (number->string (group:gid (getpw (getlogin)))) ":"
                  (group:name (getpw (getlogin)))
                  " "
                  "thumbsup --input /work --output /work/gallery")))

Docker complains about the group name.  I've tried it with both "caleb"
and "docker" with no differing results.

caleb@miller ~/Camera❄️ thumbsup 
docker: Error response from daemon: unable to find group caleb: no matching 
entries in group file.

I've tried replacing the group with `docker` as the group is associated
with my user in the system configuration.  I have the Docker service
added, too.  It should work, right?

(use-service-modules ... docker)

  (users (cons* (user-account
                  (supplementary-groups '("wheel" ... "docker")))
   (append (list
            ;; Run containers
            (service docker-service-type)

Tell me if you need more info.


Caleb Herbert
OpenPGP fingerprint: 631C C434 A56B 5CBD FF21  2346 9764 3795 FA3E 4BCE
What's a fingerprint?

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]