help-guix
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to debug failing guix pull?


From: Tomas Volf
Subject: Re: How to debug failing guix pull?
Date: Thu, 2 May 2024 16:10:52 +0200

On 2024-05-01 21:33:05 -0700, Felix Lechner via wrote:
> Hi Thomas,
>
> On Thu, May 02 2024, Tomas Volf wrote:
>
> >   Updating channel 'guix' from Git repository at 
> > 'https://git.wolfsden.cz/.git/guix'...
> >   guix pull: error: Git error: SSL error: 0xffff8880 - SSL - A fatal alert 
> > message was received from our peer
>
> Would you please try that again?
>
> On Thu May 2 04:22:58 AM UTC 2024, I ran this command
>
>     $ openssl s_client -connect git.wolfsden.cz:443 2>/dev/null | openssl 
> x509 -noout -dates
>
> and saw this output
>
>     notBefore=May  2 03:00:16 2024 GMT
>     notAfter=Jul 31 03:00:15 2024 GMT
>
> By my math, you possibly wrote your message before the certificate was
> valid, namely on or about Thu May 2 00:08:00 AM UTC 2024.
>
> Maybe Guix cared but Git didn't?

Ha, if that would be the cause it would nicely sit on the top of the pile of bad
luck I had this week.  Alas, it was not the cause.  I tried again and it still
fails with the same error.

What I did discover however is that the failure is specific to the debian
version of Guix.  When I time-machine to 1.4.0, the pull does work.  After doing
pull from the Guix upstream, the pull (from my repository) also works.  Only the
debian version is affected.

Therefore I will try reporting it to debian bug tracker.

Thanks for the help :)

Tomas Volf

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.

Attachment: signature.asc
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]