help-guix
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Where can I find the ca-certificates.crt file from the nss-certs pac


From: Reza Housseini
Subject: Re: Where can I find the ca-certificates.crt file from the nss-certs package?
Date: Fri, 17 May 2024 11:49:19 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.15.0

Hi Adam

Thanks for the response. I am using Guix System and tried to configure a configuration file for offlineimap with guix home

(simple-service 'offlineimaprc
                          home-files-service-type
                          (list `(".offlineimaprc"
                                  ,(mixed-text-file "offlineimaprc" "

[general]
accounts = Gmail
maxsyncaccounts = 3
pythonfile = ~/.config/mailpassword.py

[Account Gmail]
localrepository = Local
remoterepository = Remote

[Repository Local]
type = Maildir
localfolders = ~/Maildir

[Repository Remote]
type = IMAP
remotehost = imap.gmail.com
remoteuser = reza.housseini@gmail.com
remotepasseval = mailpassword('gmail')
ssl = yes
sslcacertfile = " nss-certs "/etc/ssl/certs/ca-certificates.crt
maxconnections = 1
"))))

yes it is a really odd behavior, because when I run guix shell nss-certs, I can find $GUIX_ENVIRONMENT/etc/ssl/certs/ca-certificates.crt...

On 5/17/24 09:39, Adam McCartney wrote:
On 2024-05-17, Reza Housseini wrote:
Hello Guix

For an application I need a ca-certificates.crt file and according to [1] I can get it from the package nss-certs, but

ls $(guix build nss-certs) | grep ca-certificates.crt
does not list any certificates, what am I doing wrong?

Best,
Reza

[1] https://guix.gnu.org/en/manual/devel/en/guix.html#X_002e509-Certificates
Hi Reza,

I think it might depend on a couple of things, are you using guix system or guix
as a package manager in a foreign distro?

Does it maybe have something to do with the _profile_ that you are using to
install the packages? I've been confused by this behaviour recently myself.
Do you know what profile you are using to install the nss-certs and the package
that requires them? And is this profile active?

If you provide a bit more info, maybe I can offer a few examples that help to
clarify.

regards,
Adam


--
Reza Housseini

This message is signed with my GnuPG key:

    C0F3 0812 9AF2 80F4 0830 C2C1 C375 C6AF 0512 5C52


reply via email to

[Prev in Thread] Current Thread [Next in Thread]