[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug#801073: src:libidn: libidn needs gettext 0.19.3 or higher

From: Simon Josefsson
Subject: Bug#801073: src:libidn: libidn needs gettext 0.19.3 or higher
Date: Tue, 13 Oct 2015 10:25:54 +0200
User-agent: Gnus/5.130014 (Ma Gnus v0.14) Emacs/24.4 (gnu/linux)

Ondřej Surý <address@hidden> writes:

> Package: src:libidn
> Version: 1.32-3
> Severity: minor
> Hi,
> I am backporting some packages and found out that libidn requires
> gettext 0.19.3 or higher.  Could you please declare this in B-D to
> help backporters?

Hi.  Thanks for the report.  Libidn does not really require a modern
gettext, but I bumped the version to 0.19.3 so that gettextize installs
the latest m4 files.  I don't think you can tell gettext to use the
latest M4 files but don't require the latest gettext.  Which gettext
version do you have?  Maybe we can lower it a bit, it was raised
arbitrarily and without any real problem prompting it.  We used to
declare 0.18.3.


>  autoreconf -f -i
>  autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your
>                      file requires the infrastructure from gettext-0.19.3 but 
> this version
>                      is older. Please upgrade to gettext-0.19.3 or newer.
>                      autopoint: *** Stop.
>  autoreconf: autopoint failed with exit status: 1
> Cheers,
> Ondrej
> -- System Information:
> Debian Release: 8.2
>   APT prefers stable-updates
>   APT policy: (500, 'stable-updates'), (500, 'stable')
> Architecture: amd64 (x86_64)
> Kernel: Linux 3.19.0-18-generic (SMP w/24 CPU cores)
> Locale: LANG=en_DK.UTF-8, LC_CTYPE=en_DK.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: systemd (via /run/systemd/system)

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]