[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: using integer

From: Dr. Wassim Znaidi
Subject: RE: using integer
Date: Thu, 21 Nov 2013 10:54:07 +0300

Thanks for the explanation.
Just another question on the same feature, I have tried to make also an 
assignment like this:

Uint8 ::= INTEGER       
ProtocolVersion ::= Uint8 (0)

But it seems also that this is not also accepted.

Does libtasn accept assigning value to field ??

-----Original Message-----
From: Nikos Mavrogiannopoulos [mailto:address@hidden On Behalf Of Nikos 
Sent: Thursday, November 21, 2013 10:37 AM
To: Dr. Wassim Znaidi
Cc: address@hidden
Subject: Re: using integer

On Wed, 2013-11-20 at 16:03 +0300, Dr. Wassim Znaidi wrote:
> HI every one,
> I am a new to libatsn and I have tried to use a definition (see 
> below), but it is always refused (when checking using asn1Parser -c)

> OneEightyDegreeInt ::= INTEGER (-1800000000..1800000001) Please any 
> help, or hint ??

It seems that the parser doesn't accept negative numbers. But that doesn't 
affect you much as libtasn1 doesn't check ranges anyway.

You can simply replace your definition with:
OneEightyDegreeInt ::= INTEGER


reply via email to

[Prev in Thread] Current Thread [Next in Thread]