[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Use of wildcard in prerequisite list failes

From: hans . peter . van . lohuizen
Subject: Use of wildcard in prerequisite list failes
Date: Wed, 27 Aug 2003 15:04:29 +0200


I have an flat archive environment with the same structure but with a different root path like:


The module_1/2/.. are sub components of module_top.
Now I want to use a generic make script that is located in the module_top/workdir that will first update all
dependencies of the sub modules and then the dependencies of the module_top.
The result (generic.db) will be put in the correponding ddb dir's below  the workdir.

Because of the large number of .vhdl files I want to use a wildcard in my prerequisites list to get  a dependence
for all .vhdl files in ../RTL dir.
First I tried the following line: (where % gets the 'stem' value:  home/<module>/workdir/)

 %ddb/generic.db : %RTL/*.vhdl

This does not work, I get the message: 'gmake: *** No rule to make target'
So obviously the * did not expand.

Now I tried the following:

%ddb/generic.db : %$(wildcard ../RTL/*.vhdl)

This works fine when I only update the toplevel dependencies (so in same dir. as where the makefile is located)
But as soon as I want to update a target of a submodule this does not work anymore.
Again I get the message: 'gmake: *** No rule to make target'

I suspect that somehow the % is not expanding in combination with the wildcard command.
I tried this with the 3.79.1 and the 3.80 gmake releases with the same (failing) result.

Does somebody have a suggestion for me how to get this working?


Hans Peter.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]