[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Platform independant shell test

From: Jason Pearce
Subject: Platform independant shell test
Date: Tue, 12 Apr 2005 18:45:55 +0100
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

I am porting a build system to run on solaris, it already works under Cygwin and Linux. In my target rules I am using the shell to check for the existance of a particular file and select which command line arguments to run the simulator with.

# Target for interactive simulation of amdtest
amdtest-cfg : ${pre}configuration-amdtest_cfg-of-${TESTBENCH_ENTITY} util_rom/jump_rom.mem flash_srom/amdtest.mem
      echo recompile: $^ > recompile.mak
      if [ -e ]; then \
              ${GUISIM} ${SIMOPT} amdtest_cfg -do; \
      else \
${GUISIM} ${SIMOPT} amdtest_cfg -do ${TESTBENCH_ENTITY}.do; \

When I run this under SunOS I get
/bin/sh: test: argument expected

I also tried changing the if to this format.

if test -e ; then

but there was no change.

Whats the trick with Solaris? Thanks.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]