[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Make doesn't honor .SHELLFLAGS?

From: Warlich, Christof
Subject: RE: Make doesn't honor .SHELLFLAGS?
Date: Thu, 25 Oct 2012 11:15:03 +0200

Ah, thanks a lot: I tried with V3.81, and it doesn't work with that version.

It _does_ work with V3.82.90 for me as well. :-)

By the way:

Could anyone tell why GNU Make developnemt seems to be somewhat detached
from Linux (distributions) for such a long time?
All Linux distributions I know are still using V3.81, and as much as I
recall, building glibc with V3.82.90 failed, while it built fine with V3.81.

I know this is all volunteer work, which I do appreciate very much, so
please don't interpret my question as criticism, I'm just curious to know
why, say V3.82.90, is not officially released (after such a long time)
and why, up to now, the latest official release (V3.82) is not used
downstream, i.e. by distributions and (GNU) tools.



-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Greg Chicares
Sent: Donnerstag, 25. Oktober 2012 10:41
To: address@hidden
Subject: Re: Make doesn't honor .SHELLFLAGS?

On 2012-10-25 06:57Z, Warlich, Christof wrote:
> I'd like to have Make to use a shell that executes a specific init file.
> I tried the following, but it doesn't work:
> echo "echo -n Hello">xxx && make SHELL=/bin/bash .SHELLFLAGS="--init-file xxx 
> -i -c"

Seems to work for me:

$ echo "echo -n Hello">xxx && make SHELL=/bin/bash .SHELLFLAGS="--init-file xxx 
-i -c"
Hello World

$ make --version
GNU Make 3.82.90
Built for i686-pc-cygwin ...

$ bash --version
GNU bash, version 4.1.10(4)-release (i686-pc-cygwin) ...

> The Makefile may be as simple as:
> all: ; @echo " World"
> but I only see:
> $ make
> World
> while I'd expect:
> $ make
> Hello World

Just to be're using the full 'echo ...' command above,
and not just typing 'make' at the command line, right?

$ make

Does it make a difference if you specify '/bin/echo -n ...',
to get the 'echo' binary instead of a shell builtin?

- echo "echo -n Hello">xxx ...
+ echo "/bin/echo -n Hello">xxx ...

> By the way: This works:
> $ echo "echo -n Hello">xxx && /bin/bash --init-file xxx -i -c "echo \" 
> World\""
> Hello World

That works here, too:

$ echo "echo -n Hello">xxx && /bin/bash --init-file xxx -i -c "echo \" World\""
Hello World

Help-make mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]