[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-mcsim] configure: error: You first need to install the 'gslcblas'

From: Bill Harris
Subject: [Help-mcsim] configure: error: You first need to install the 'gslcblas' library to build MCSim
Date: Mon, 03 May 2010 22:28:43 -0700
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

This is mildly embarrassing, for I think I should know what to do.  I'm
coming back to MCSim for some work I need to do -- work I intended to do
tonight -- and I'm stuck.

I'm running Ubuntu 9.10 (32-bit), and I just installed MCSim v5.3.1.  I
first tried from CVS, but I couldn't find configure, so I grabbed the
tarball, and that worked.

Then I tried configure and got

| ~/bin/mcsim-v5.3.1/mcsim$ ./configure
| checking for gcc... gcc
| checking for C compiler default output file name... a.out
| checking whether the C compiler works... yes
| checking whether we are cross compiling... no
| checking for suffix of executables... 
| checking for suffix of object files... o
| checking whether we are using the GNU C compiler... yes
| checking whether gcc accepts -g... yes
| checking for gcc option to accept ANSI C... none needed
| checking for a BSD-compatible install... /usr/bin/install -c
| checking whether make sets $(MAKE)... yes
| checking for gzip... yes
| checking for gnuplot... yes
| checking for wish... yes
| checking for info... yes
| checking for install-info... yes
| checking for makeinfo... yes
| checking for gv... yes
| checking for touch... yes
| checking for date... yes
| checking for tex... yes
| checking for texi2dvi... yes
| checking for dvi2ps... no
| checking for texi2html... yes
| checking for main in -lm... yes
| checking for main in -lgslcblas... no
| configure: error: You first need to install the 'gslcblas' library to build 

I found and  Running
sudo ldconfig -v didn't help.  I gather you only need to set
LD_LIBRARY_PATH if libgsl isn't in /usr/lib, but

|   /usr/lib:
|   total used in directory 488844 available 15233936
|   .
|   .
|   .
|   lrwxrwxrwx   1 root root       20 2009-11-29 18:04 ->
|   -rw-r--r--   1 root root   226580 2008-12-22 05:28
|   lrwxrwxrwx   1 root root       16 2009-11-29 18:04 ->
|   -rw-r--r--   1 root root  1964616 2008-12-22 05:28
|   .
|   .
|   .

I did try 

| ~/bin/mcsim-v5.3.1/mcsim$ export LD_LIBRARY_PATH=/usr/lib
| ~/bin/mcsim-v5.3.1/mcsim$ echo $LD_LIBRARY_PATH

but ./configure still failed in the same way.

Finally, I found an old email from Frédéric suggesting to use 

| gcc *.c -lm -lgsl -lgslcblas 

instead of make.  I tried running find to find *.c files and pass them
to gcc, but that failed with lots of 

| /usr/bin/ld: cannot find -lgsl
| collect2: ld returned 1 exit status

and other errors.

I did have 5.2.beta working sometime in late 2008 / early 2009, but I've
been away from it since then.  Can anyone point out the obvious error in
my ways?  I now have a real need for MCMC applied to a dynamic model.


Bill Harris        
Facilitated Systems                              Everett, WA 98208 USA               phone: +1 425 374-1845

reply via email to

[Prev in Thread] Current Thread [Next in Thread]