[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Help-nano] Configuring question

From: FISCHER Janice
Subject: RE: [Help-nano] Configuring question
Date: Thu, 5 Feb 2004 15:12:16 -0800

Thank you Jordi.  My problem is I'm taking a class...and this instructor wants 
us to compile from source instead of just installing the rpm.  Seems a bit of 
overkill for a fairly beginner class, but there you have it, he wants it, he's 
the boss.

I used "locate" and found gettext in usr/lib
I found a lot of gcc entries in /usr/bin and /usr/lib
Can't find anything called ncurses-devel

Is it possible that I don't have PATH set up correctly?  I haven't mucked with 
it. It's the RH9 default


I tried ./configure --with-included-gettext
Still got told "no acceptable c compiler in $PATH"
Is there a difference between "gcc296" and "gcc"?
-----Original Message-----
From: Jordi Mallach [mailto:address@hidden 
Sent: Thursday, February 05, 2004 1:55 PM
To: FISCHER Janice
Cc: address@hidden
Subject: Re: [Help-nano] Configuring question

Hi Janice,

On Thu, Feb 05, 2004 at 01:36:59PM -0800, FISCHER Janice wrote:
>    I'm a Linux newbie.  I downloaded nano and tried ./configure.  Got an
>    error message "no acceptable C compiler found in $PATH"
>    What C compiler do I need?  I have RH9, didn't install any developer
>    tools.

You will most probably need to install: gcc, ncurses-devel and gettext. I don't 
know the package names in Red Hat, but you probably have some tool to search 
for them easily. If not, feel free to mail back to the list, I'll query the 
exact package names / commands to get it installed.

Also, nano should be packaged in rpm format already. You probably want to 
install the package instead of compiling it yourself, it'll be a lot easier.

Jordi Mallach PĂ©rez  --  Debian developer
address@hidden     address@hidden
GnuPG public key information available at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]