[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-nano] numlock probs since v1.0.x

From: Chris Allegretta
Subject: Re: [Help-nano] numlock probs since v1.0.x
Date: Tue, 1 Jun 2004 17:44:56 -0400
User-agent: Mutt/1.3.28i

On Tue, Jun 01, 2004 at 10:50:09AM -0500, address@hidden wrote:
> What would have changed since version 1.0 that would break numlock and the 
> numberpad?
> When the numlock is pressed, help comes up, and 0-9 on the num pad are "_" 
> "\" "^" "]" "^M" "^N" "^O" "^Q" "^R" "^H".
> I don't get this on a console, only from a terminal emulator like TeraTerm 
> and Putty.  I've tried both vt100 and xterm.
> I've tested this on v1.1, 1.2 and 1.3 and get the same thing.  Versions 
> 1.0 and earlier work fine.  I've also tried dozens of compile option 
> combinations.

Hi Vincent,

        Have you tried the -K option?  Nano by default now calls the
keypad() curses routine, which some terminals have a problem with.  -K
tried to avoid that call at all costs...

Chris A
Chris Allegretta


Attachment: pgp7lWOyjGDJu.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]