[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-nano] Configuration issue with Nano

From: David Lawrence Ramsey
Subject: Re: [Help-nano] Configuration issue with Nano
Date: Mon, 30 Jan 2006 15:15:15 -0500
User-agent: Thunderbird 1.5 (X11/20051201)

Wayne Parker wrote:
> Hello,
> I'm a longtime Pico user now involved in bringing up numerous
> replacement servers which are running Linux.  I would like to be able
> to use Nano, particularly as it appears to have added some
> long-missing functionality that Pico lacks.

That's good to know.

> However, when I run Nano on the first of the new servers, it appears
> to be somewhat misaligned with the screen.  The cursor is stuck
> (immovable) in the first position of the very top line (the
> highlighted Banner line), rather than the first position of the second
> line (as it should be).
> The top of the two control-key menu lines at the bottom is missing;
> the second menu line at the bottom is moved up one line, to where the
> first menu line should be.
> If you start using control keys, program text starts showing up on the
> wrong lines, at the wrong position, wrapping incorrectly, etc.
> Furthermore, I tried loading an 8-line file to edit, and although it
> says it has it for editing, the file is not displayed on the screen.

Hmmm.  Is everything displayed properly after pressing Ctrl-L to refresh
the screen?

> Does this sound like a common misconfiguration that you recognize?

Unfortunately, no.

> It does appear to me as though somehow the program believes it has
> either fewer or more lines and/or character positions to work with
> than it actually has, but I don't know for sure.

There are a few ways to find out.  Do other curses-based programs
malfunction in similar ways?  If you set the environment variables LINES
and COLUMNS to the number of lines and columns in your terminal before
running nano, does nano (and/or other curses-based applications) work

> I don't have a .nanorc file, and don't know that there is one on the
> system either (at least I haven't found it).
> The Nano version is 1.2.4.  It is on an HP Proliant, running Linux Red
> Hat Enterprise 4.0 in 64-bit version (for AMD Opteron).  I am using
> korn shell as my shell, and the session is an xterm one.
> Any ideas?  I'd appreciate any help.

Thanks for the info.  I hope I've been of some help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]