[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mkoctfile not working

From: Jeff Mason
Subject: mkoctfile not working
Date: Tue, 13 May 1997 11:08:43 -0600

I cant get mkoctfile to work - Im using Octave 2.0.5 on
sparc-sun-solaris2.5.1 . I configured with --with_f2c
and I do see -DWITH_DYNAMIC_LINKING=1. With the original
mkoctfile script I got thousands of error messages from
the last line of the script (linking). I removed the
-shared option and then got only a few undefined syms
like "dlopen" and "dlclose" so I changed the definition
LIBDLFCN="" to LIBDLFCN="-ldl" and then was only getting
MAIN__ undefined. I have tried putting -u MAIN__ in
several places such as:

$CXX -u MAIN__ -o $octfile $objfile $LIBFLAGS $RLD_FLAG $OCTAVE_LIBS $FLIBS 

,as well as CPPFLAGS=" -u MAIN__", but I still get:

112 address@hidden:ex % mkoctfile
making hello.o from
making hello.oct from hello.o
Undefined                       first referenced
 symbol                             in file
MAIN__                              (command line)
ld: fatal: Symbol referencing errors. No output written to hello.oct
113 address@hidden:ex %

I dont know if Im on the right track here or just thrashing.
Any suggestions?

Thanks -- Jeff

Jeff Mason               |     Radar Analysis Dept.
Mail Stop 0537           |     Dept. Number 2344
Sandia National Labs     |     address@hidden
PO Box 5800              |     phone (505) 845-8565
Albuquerque, NM 87106    |     FAX (505) 845-9888

reply via email to

[Prev in Thread] Current Thread [Next in Thread]