[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Announce: New graphics package, PLplot_octave

From: Joao Cardoso
Subject: Re: Announce: New graphics package, PLplot_octave
Date: Mon, 06 Apr 1998 16:58:50 +0100

(Ted Harding) wrote:
> cd tmp; make default
> make[1]: Entering directory `/root/plplot-octave/plplot/plplot-961023/tmp'
> make[1]: *** No rule to make target `stupidtk.c', needed by `stupidtk.o'.  
> Stop.
> make[1]: Leaving directory `/root/plplot-octave/plplot/plplot-961023/tmp'
> make: *** [all] Error 2
> I seem to have solved it with
> /root/plplot-octave/plplot/plplot-961023 # cp bindings/tk/stupidtk.c tmp
> from the plplot-961023 directory that the tar file unpacks into. However, this
> is not the correct solution which is to mend the Makefile!

This is odd. When you configure plplot, in directory plplot-961023, it
directory tmp and makes symbolic links to the sources; then, make
proceeds in the
tmp directory.
The best way to restart, is to delete directory tmp and reconfigure.
Then, `cd tmp;make'

> *** Having done that, there is yet another problem!
> After "make cdemos", many C functions compile to .o and then
> gcc -c -DDOUBLE    -O  x17c.c
> x17c.c:33: poll.h: No such file or directory
> make[1]: *** [x17c.o] Error 1
> make[1]: Leaving directory `/root/plplot-octave/plplot/plplot-961023/tmp'
> make: *** [cdemos] Error 2
> I solved this one by editing examples/c/x17c.c to change
> #include <poll.h>
> to
> #include <.usr/include/sys/poll.h>
> since that's where my (S.u.S.E-5.1 Linux) system has it ...

You could just comment these references to poll(); they are intended to
a small (10 ms) delay. I will change that to select() in the future, or
just drop it.
This one is in the FGA.

> *** And, having done that, there's still another problem:
> The library gets into
> /usr/local/plplot/lib/

This mean that you have not configured Tk, otherwise a libplplotdtk.xx
should appear.

> but when you try to run the cdemos you get, for each demo:
> ./x01c: can't load library ''

You dont need to install to run the plplot demos; `make cdemos' links
against in the tmp directory, so if you don't have
to the tmp directory probably the library can't be found. try `ldd x01c'
and see were
it expect the library to be found. You can also try, in the tmp

Please remember that plplot configure/makefiles/etc are a bit old, and I
have not
change anything. In fact, RLab uses plplot and advises to not using
shared libs.
However, I had no problems in using it in Debial Linux. As I don't use
Linux very
often, I am afraid I can't help much more.

Keep trying, and thanks,

PS: a correction to the FGA: in Linux I used gcc-, and in SCO I
used egcc

Joao Cardoso                    |       e-mail: address@hidden
INESC, R. Jose Falcao 110       |       tel:    + 351 2 2094345
4050 PORTO, PORTUGAL            |       fax:    + 351 2 2008487

reply via email to

[Prev in Thread] Current Thread [Next in Thread]