[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make trouble with octave-forge

From: Robert Leach
Subject: Re: make trouble with octave-forge
Date: Wed, 25 Feb 2004 15:27:00 -0700

Hmmm... OK, this may be a dumb question, but how can I tell if I used --enable-shared when I compiled octave? I can't remember whether I used it or not. I tried grepping the contents of the octave directory for it, but didn't see any clear indicator.


On Wednesday, February 25, 2004, at 02:50 PM, Dmitri A. Sergatskov wrote:

Robert Leach wrote:
I tried it with and without. Same error. Here's the last attempt if you want to look through it. I just now noticed an error in the configure output: (term.h: present but cannot be compiled).
plague: /usr/local/octave-forge-2004.02.12>./configure --with-path=/usr/local/octave-forge-2004.02.12 --prefix=/usr/local --enable-shared

You need to compile octave-2.1.50 (octave proper not octave-forge) with --enable-shared. Essentially you need a shared octave library to compile .mex files against.



= Robert W. Leach                                                   =
= Los Alamos National Lab                                           =
= Bioscience Division: Bioinformatics & Computational Biology Group =
= MS M888                                                           =
= Los Alamos, NM 87545                                              =
= address@hidden                                                 =
= Work: 505-667-2307                                                =
= Cell: 505-310-3759                                                =
Work Calendar & To-Do List:

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]