[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installation of Symbolic Toolbox

From: Paul Kienzle
Subject: Re: Installation of Symbolic Toolbox
Date: Mon, 22 Aug 2005 22:50:08 -0400

On Aug 22, 2005, at 8:18 AM, Kai Börner wrote:


Before installing the symbolic toolbox I installed cln 1.1.9 and Ginac 1.3.2. My octave version is 2.1.71 and I am using Cygwin. Afterwards I tried to install the symbolic toolbox but encountered some problems. May someone can help me solve them. The first error I expirienced was:

g++ -c -I/usr/local/include/octave-2.1.71 -I/usr/local/include/octave-2.1.71/octave -I/usr/local/include -mieee-fp -g -O2 -I/usr/local/include -I/usr/local/include -o ov-ex.o macro "DEFINE_OV_TYPEID_FUNCTIONS_AND_DATA" requires 3 arguments, but only 2 given error: ISO C++ forbids declaration of `
make: *** [ov-ex.o] Error 1

I tried to fix this problem by simply adding a third argument "sym" at the else part.

DEFINE_OV_TYPEID_FUNCTIONS_AND_DATA (octave_ex, "ex", "sym");

This sounds more like a configuration error to me. Check the config.log for TYPEID_HAS_CLASS to see if it provides any hint as to why this is not being defined.

That worked so far till a second error occured:

rm -f vpa.oct
symbols.oct vpa.oct
make: execvp: symbols.oct: Permission denied
make: *** [vpa.oct] Error 127

I would be glad if someone could enlight me.

Try removing symbols.oct before building. If you can't, maybe you are running octave with symbols() already loaded? Windows won't let you remove a file if another process has it open. Maybe renaming it will work, but I haven't tried. Otherwise you will have to quit octave, rebuild, and start octave again.

- Paul

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]