[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Fwd: libsz.2.dylib]

From: Ursula Perez-Salas
Subject: [Fwd: libsz.2.dylib]
Date: Fri, 19 Jan 2007 16:46:49 -0600
User-agent: Thunderbird (Macintosh/20061207)

Hi again:

I continued to look for a solution and basically gave up and decided to uninstall and start all over again. Well that fixed it. Here is what happened:

Since I had to reinstall a bunch of software after my crash I did "update all" 
in fink commander. Just to check, I separately made sure gcc, g77 and octave had been 
updated, which according to finkcommander they were.

After that I tried recompiling some code since my executables were not working. Well the command "make" did 
not work. "octave" didn't work either. I went to hpc site and downloaded gcc, g77 and octave and followed the 
instructions to install the binaries. After that "make" worked. "octave" continued to give me the 
message I sent you in the previous message. So as I mentioned above, I gave up and wanted to uninstall. I read this 

I used this command:

dpkg -c /sw/var/cache/apt/archives/octave_2.1.71-1006_darwin-powerpc.deb

and sw/bin/octave

was not listed so I uninstalled octave (through  finkcommander) and removed the 
deb file and then I reinstalled the tar file from hpc and now octave works too!

As a final note. It was interesting that fink installed/updated octave_2.1.71 
but when I installed the binary from hpc (which contains octave 2.9.9) it did 
not overwrite/erase 2.1.71 so in fact when I typed the command above the octave 
2.9.9 deb file did not even exist. There was some conflict that was resolved by 
uninstalling 2.1.71 and removing its deb file.

Thanks for your patience.



--- Begin Message --- Subject: libsz.2.dylib Date: Fri, 19 Jan 2007 12:57:30 -0600 User-agent: Thunderbird (Macintosh/20061207)
Hi ,

I installed Octave (and octave-forge from in May-June of 2006 and everything was running well on my PowerBook G4 (OS 10.4.8 and a 1GHz processor). My computer crashed a couple of weeks ago and I had to do an "archive and reinstall" of os x. I also reinstalled x11and xcodetools pkg. I also found that on top of that I had to reinstall gcc and g77 manually from HPC site (fink, which I tried first, didn't do the job). I installed the octave-forge binary from hpc as well but it didn't work since I continue to get this error message after I type octave at a terminal prompt:

dyld: Library not loaded: /sw/lib/libsz.2.dylib
 Referenced from: /sw/lib/libhdf5.0.dylib
 Reason: image not found

what should I do to make it work?



--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]