[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: fntests errors on mingw-Octave

From: Tatsuro MATSUOKA
Subject: Re: fntests errors on mingw-Octave
Date: Thu, 3 Jan 2008 07:43:02 +0900 (JST)

Hello John

--- "John W. Eaton" <address@hidden> wrote:
> I don't think it would be a waste of time to fix these tests so that
> they work properly on Windows and Unixy systems.

OK. I see!!  We have to solve the problems.  
As I have reported, the test under the cygwin was almost complete except for
The problem has been aalready solved by David. 
The cygwin environments give posix emulation so that it is rather unixy but not 
windows like from the
point of view of the fntests.    

We have to come back to Michael's first mail which is cited at the end of the 
main for convinience. 
This is because the failures on mingw are similar to those by Michael. 

The differences are described the below:

Mingw intrinsic;
>  octave-3.0.0\src/  PASS    2/3    FAIL 1
  ***** test
 a = 2;
 f = @(x) a + x;
 g = @(x) 2 * x;
 h = @log2;
 f2 = f;
 g2 = g;
 h2 = h;
 nm = tmpnam();
   save ("-text", nm, "f2", "g2", "h2");
   clear f2 g2 h2
   load (nm);
   assert (f(2),f2(2));
   assert (g(2),g2(2));
   assert (g(3),g2(3));
   unlink (nm);
   save ("-text", nm, "f2", "g2", "h2");
   unlink (nm);
!!!!! test failed
error: function handle points to non-existent function

>  + test_io.m freezes during the test.
MSVC intrinsic
 test_string - 1 failure

We have to discuss the common problems and the intrinsic problems

We begin with the commom problem first. - 2 failures
 2.general/bitcmp.m - 1 failure
 3.test_system - 14 failures

Oh! I forget to discuss that it is allowable the 'fntests' have platform 
dependent parts.
Otherwise nothing goes forward.

I'll wait the replies.



Michel's mail

The package compiles fine under MSVC. I ran the test suite and
here are the results: - 2 failures
These are due to the fact the argument to
"system" is not run into a shell, so something like
system("echo 'something'>file.out") does not generate file.out; hence
the dispatch tests that use this trick to produce temporary m-file fail.

general/bitcmp.m - 1 failure
 ***** assert(bitcmp(A,Amax),bitor(bitshift(1,Amax-1),bitshift(1,Amax-2)));
!!!!! test failed
error: assert (bitcmp (A, Amax),bitor (bitshift (1, Amax - 1),
bitshift (1, Amax - 2))) expected
but got
values do not match
shared variables {
 Amax =  53
 Bmax = 9.0072e+015
 A = 2.2518e+015

test_string - 1 failure
This is due to the fact that under MSVC: isprint(setstr(9)) == 1,
while the test expects 0.

test_system - 14 failures
The reasons are various:
- stat(filesep) fails; what works is stat('\\') or stat('C:\')
- getpwuid, getprgp, getppid, getpwent, getgrent are not implemented
- doing "cd /" and "pwd ()" does not give you "/", but something
including the current drive letter (like "d:\")

In summary, almost all failures are "expected" under MSVC. The only
one that could be problematic is the one related to bitcmp. However,
as I'm no expert, I don't really understand what's going on.

Easy + Joy + Powerful = Yahoo! Bookmarks x Toolbar

reply via email to

[Prev in Thread] Current Thread [Next in Thread]