[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnuplot no longer works

From: Thomas Treichl
Subject: Re: gnuplot no longer works
Date: Mon, 18 Feb 2008 20:55:53 +0100
User-agent: Thunderbird (Macintosh/20071031)

Dushan Mitrovich schrieb:
I'm using Octave 3.0 under Mac OSX and have also installed gnuplot 4.2.2
that was included in the package.  After the initial install, gnuplot
displayed the plots as expected.

About a month ago, on the advice of AppleCare Support to try to fix an-
other, unrelated problem (getting FTP transfers to work), I did a so-called
'archive-install'.  After that, not only did the FTP problem persist, but
I've been discovering a number of other imporatnt things that no longer
worked, e.g. printing, and now gnuplot.  Here's what happens.

I've re-installed Xcode, X11, and AquaTerm, and also gnuplot.  To test
it out I invoked gnuplot by itself, with out going thru Octave.  First I
opened AquaTerm, then gnuplot, and tried to plot the sine function using

I don't know what is going wrong on your Mac now. However, brings its own AquaTerm.framework that should be started automatically when needed by It is placed in


Try not to startup another AquaTerm manually that might either be buggy or version incompatible or whatever. One idea would be to completely remove from your Applications folder

  rm -rf /Applications/

and then reinstall that one again. Make sure that you have quit the manually started AquaTerm (wherever it comes from) and then try again. If this all doesn't help then a switch to X11 will. Therefore you need to

  export GNUTERM=x11 # watch out lower case letter x

*before* you startup or put the 'export' line into your ~/.profile file so that it will be found everytime you launch The curious thing is that cannot be connected correctly *after* you already started You can also try to set a line 'export GNUTERM=aqua' in your .profile file - maybe this helps for you?!

Let us know if something helps for you...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]