[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnuplot no longer works

From: Ben Abbott
Subject: Re: gnuplot no longer works
Date: Wed, 20 Feb 2008 19:53:38 -0500

On Feb 20, 2008, at 3:27 PM, Dushan Mitrovich wrote:

Ben Abbott <address@hidden> wrote:
I'm not familiar with macports (I use Fink), but what does the
following pair of commands give you

 $ echo $GNUTERM

You might also check your path to be sure that the corrent gnuplot
will be encountered first.

 $ echo $PATH

My path points to the applications installed by Fink first.


I can't say if the problem is due to your duplicate gnuplots, or due
to different version of gnuplot, or something else. However, if you
have no reason for such an installation, I'd prune down to a single

Ben, I tried these 'echo' commands both within Terminal and within Octave
( using 'system('echo $...') ).  Here are the results in table form.
                      ________           ______
              within  Terminal           Octave

   echo $GNUTERM      <blank>            ans = 0

   echo $GNUTERMAPP   <blank>            ans = 0

   echo $PATH         /opt/local/bin:    AOCRlo/3.0.0/site/eiad:
                      /opt/local/sbin:   AOCRlo/api-v32/site/eiad:
                      /bin:/sbin:        AOCRlo/site/eiad:
                      /usr/bin:          AOCRlo/3.0.0/eiad:
                      /usr/sbin          AOCR/bin:

where  AOCR = /Applications/
      AOCRlo = AOCR/libexec/octave
      AGCR = /Applications/
      eiad = exec/i386-apple-darwin8.9.1

and the PATH entries were separated to individual lines for clarity.

I notice that nowhere in the PATH are there references to either X11 or AquaTerm. When I /Applications/Utilities/ manually, set GNUTERM to
x11, then ask Octave to plot, again nothing happens.

BTW, I deleted all but the Octave version of gnuplot.  In my reply to
Thomas Treichl I describe other things I tried. Any further ideas would be

- Dushan

Thomas will hopefully more insight that I.

I don't use MacPorts. However, I do use Fink.

I've avoided conflicts by installing all my unix-style apps via Fink.

Regarding your problem, I'd try using MacPorts package manager to remove its version of gnuplot, aquaterm, and octave (if you have a MacPorts version installed). I'm not familiar with how and where MacPorts installs any of these, but expect there are both binaries and libraries involved. So it is important that the package manager be used to do the job.

Then check to see if the Octave installed in the Applications directory is functional or not.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]