[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: embedding octave - floating point exception

From: Marco Driusso
Subject: Re: embedding octave - floating point exception
Date: Tue, 10 Mar 2009 18:28:40 +0100

Some news: I tried to embed octave in a simplier c++ program, and everything works: no compilation or linking problems (as with the bigger one), but also no floating point exception when octave_main is called. Everything works, octave runs, executes his functions and terminates correctly. I think that the problem is in the bigger program Makefile. I hope this informations could be useful.


2009/3/9 Marco Driusso <address@hidden>
Yes I'm using exactly the same libraries, liboctinterp, liboctave and libcruft.
Could be the problem caused by some compiling options in the makefile? (I hask for that because I noted that when you call mkoctfile, this one calls gcc with the option -miee-fp, option that I don't have in my Makefile). Thanks again.


Il giorno 09/mar/09, alle ore 22:43, John W. Eaton ha scritto:

On  9-Mar-2009, Marco Driusso wrote:

| Running my program under gdb, after some functions that end correctly, I get
| Program received signal SIGFPE, Arithmetic exception.
| [Switching to Thread 0xb5d176c0 (LWP 15573)]
| octave_ieee_init () at
| 86            if (tmp_inf == tmp)
| Current language:  auto; currently c++

and earlier you wrote:

| > | But octave run correctly on my system, I've not such error when I run it
| > | normally from a shell.

For your progmam that embeds Octave, are you using the same libraries
(liboctinterp, liboctave, libcruft) that are used by the copy of
Octave that runs correctly?  If so, then I don't understand how this
can work correctly for Octave but not for your program.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]