[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Install packages in Mac OS X

From: Ben Abbott
Subject: Re: Install packages in Mac OS X
Date: Wed, 09 Sep 2009 15:02:40 -0400

On Wednesday, September 09, 2009, at 02:15PM, "Thomas Treichl" <address@hidden> 
>Vic Norton schrieb:
>> I don't have Snow Leopard yet, but you might try this. It works for me.
>>     1) Download " for Mac OS X" from
>>           <>.
>>     2) Drop the Octave application into your Applications folder.
>>     3) To be able to use the shebang line
>>           #!/usr/local/bin/octave
>>        in your scripts, do
>>           $ sudo ln -s \
>>             /Applications/ \
>>             /usr/local/bin
>>        in Terminal.
>> Regards,
>> Vic
>> On Sep 8, 2009, at 8:28 PM, Xin Dong wrote:
>>> Hi,
>>> Has anyone successfully installed octave-forge packages with snow
>>> leopard and octave 3.2.2? I tried to install image-1.0.10.tar.gz, but
>>> failed.
>Hi Vic, hi Xin,
>I think the problem is a bit more complex. Apple has changed some more things 
>from Leopard to Snow Leopard and with Snow Leopard everything that has to do 
>with Octave's mkoctfile is broken now (ie. installing packages, the 
>command itself, the command 'mex', and so on) - in detail: Snow Leopard's 
>does not accept my 10.4 build libraries anymore and that's why linking against 
>my binaries completely fails. I've already commented on a similar problem here
>Just because of my own interest - what is the current GCC version from Snow 
>Leopard's XCode tools? Is there at least a gfortran available?
>Best regards
>   Thomas

Hi Thomas,

I've been running Snow Leopard since the morning it was released.

$ gcc --version
i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5646)

I don't think gfortran is included (it's not in /usr/bin).

The biggest annoyance has been that the old .la files no longer work (my Fink 
packages are currently a mess). I deleted all .la files in the Fink directory 
structure and rebuild the appropriate package when an .la file comes up missing.

I can *almost* build a functioning Octave. It compiles, but crashes during 
"make check". If I run and then exit, I get a core dump. I wish I had time to 
look into what is happening but I have very little spare time at present.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]