[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: (jhandles installs.... then error) Implementation of "uicontrol" for

From: Martin Helm
Subject: Re: (jhandles installs.... then error) Implementation of "uicontrol" for latest Octave?
Date: Tue, 24 Aug 2010 18:23:34 +0200
User-agent: KMail/1.13.5 (Linux/; KDE/4.4.4; x86_64; ; )

Am Dienstag, 24. August 2010, 18:02:45 schrieb Pen-Yuan Hsing:
> OK, since I use a Mac I just tried the whole thing in a Parallels
> Desktop 5 virtual machine (same configuration).
> This time, sombrero and shading interp seemed to work, and glxgears,
> etc. showed correctly.
> However, when I ran my Matlab code, which uses the uicontrol function, I
> get the following output:
> octave:6> mosaic_GUI
> error: [java] property not found
> - Units
> error: evaluating argument list element number 1
> error: evaluating argument list element number 1
> error: called from:
> error:   /usr/share/octave/packages/3.2/jhandles-0.3.5/__jhandles_get.m
> at line 41, column 5
> error:   /home/penyuan/Downloads/photo_mosaic/mosaic_GUI.m at line 7,
> column 12
> BTW, "mosaic_GUI" is the name of the Matlab program I am trying to run.
> Is this a limitation on jhandles part? Or is it still a virtual machine
> issue?
So far this is success. There is no problem left which has to do with opengl 
or virtual machine.

The error you get is obviously a limitation in the jhandles, mosaic_GUI.m 
seems to set a property which does not exist in jhandles, you will need to 
make some changes to your original code to make it compatible (this is more 
often the case since octave is very matlab compatible but not 100%).

Since this happens very early in the mosaic_GUI.m (line 7), can you post the 
first lines of this script including the one which reports the error and the 
parameters with which you call it? Maybe it is a trivial change to make it 

> Is vmware the only one that is known to work?

Vmware is besides qemu (which is not a virtualization but an emulation 
software) the only one I have experience with, so I cannot answer this 
question. I guess most will work, virtual box seems to have a special bug in 
its opengl.

- Martin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]